月度归档:2018年04月

python升级后pip不能用解决方法

 

升级完python2.7后pip不可用,还是老的2.6下的,需要升级Pip到2.7下

按这个方式安装pip:

 

 

官网文档:

https://pip.pypa.io/en/stable/installing/

然后:

# whereis pip

pip: /usr/bin/pip /usr/bin/pip2.6 /usr/local/bin/pip2.7 /usr/local/bin/pip

直接用这个安装需要的包就是2.7的了:

/usr/local/bin/pip install requests

mongodb连接

 

  1. 下载mongodb压缩包

curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.0.6.tgz

mongodb-linux-x86_64-3.0.6.tgz

  1. 解压

$ tar zxvf mongodb-linux-x86_64-3.0.6.tgz

  1. 进入bin目录

$ cd mongodb-linux-x86_64-3.0.6/bin

  1. 连接远程数据库

$ mongo 192.168.1.200:27017/database  -u user  -p  password